summaryrefslogtreecommitdiffstats
path: root/third_party/rust/neqo-qpack/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/neqo-qpack/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/neqo-qpack/Cargo.toml')
-rw-r--r--third_party/rust/neqo-qpack/Cargo.toml43
1 files changed, 43 insertions, 0 deletions
diff --git a/third_party/rust/neqo-qpack/Cargo.toml b/third_party/rust/neqo-qpack/Cargo.toml
new file mode 100644
index 0000000000..a8fcbb2bca
--- /dev/null
+++ b/third_party/rust/neqo-qpack/Cargo.toml
@@ -0,0 +1,43 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.57.0"
+name = "neqo-qpack"
+version = "0.6.4"
+authors = ["Dragana Damjanovic <dragana.damjano@gmail.com>"]
+license = "MIT/Apache-2.0"
+
+[dependencies]
+lazy_static = "1.3.0"
+qlog = "0.4.0"
+static_assertions = "1.1.0"
+
+[dependencies.log]
+version = "0.4.0"
+default-features = false
+
+[dependencies.neqo-common]
+path = "./../neqo-common"
+
+[dependencies.neqo-crypto]
+path = "./../neqo-crypto"
+
+[dependencies.neqo-transport]
+path = "./../neqo-transport"
+
+[dev-dependencies.test-fixture]
+path = "../test-fixture"
+
+[features]
+default = ["deny-warnings"]
+deny-warnings = []