summaryrefslogtreecommitdiffstats
path: root/third_party/rust/phf_generator/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/phf_generator/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/phf_generator/Cargo.toml')
-rw-r--r--third_party/rust/phf_generator/Cargo.toml40
1 files changed, 40 insertions, 0 deletions
diff --git a/third_party/rust/phf_generator/Cargo.toml b/third_party/rust/phf_generator/Cargo.toml
new file mode 100644
index 0000000000..53394ab308
--- /dev/null
+++ b/third_party/rust/phf_generator/Cargo.toml
@@ -0,0 +1,40 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "phf_generator"
+version = "0.10.0"
+authors = ["Steven Fackler <sfackler@gmail.com>"]
+description = "PHF generation logic"
+license = "MIT"
+repository = "https://github.com/sfackler/rust-phf"
+
+[[bin]]
+name = "gen_hash_test"
+required-features = ["criterion"]
+
+[[bench]]
+name = "benches"
+harness = false
+[dependencies.criterion]
+version = "=0.3.4"
+optional = true
+
+[dependencies.phf_shared]
+version = "0.10.0"
+default-features = false
+
+[dependencies.rand]
+version = "0.8"
+features = ["small_rng"]
+[dev-dependencies.criterion]
+version = "=0.3.4"