summaryrefslogtreecommitdiffstats
path: root/third_party/rust/prio/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/prio/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/prio/Cargo.toml')
-rw-r--r--third_party/rust/prio/Cargo.toml148
1 files changed, 148 insertions, 0 deletions
diff --git a/third_party/rust/prio/Cargo.toml b/third_party/rust/prio/Cargo.toml
new file mode 100644
index 0000000000..bf07b5972c
--- /dev/null
+++ b/third_party/rust/prio/Cargo.toml
@@ -0,0 +1,148 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.58"
+name = "prio"
+version = "0.9.1"
+authors = [
+ "Josh Aas <jaas@kflag.net>",
+ "Tim Geoghegan <timg@letsencrypt.org>",
+ "Christopher Patton <cpatton@cloudflare.com",
+ "Karl Tarbe <tarbe@apple.com>",
+]
+description = "Implementation of the Prio aggregation system core: https://crypto.stanford.edu/prio/"
+readme = "README.md"
+license = "MPL-2.0"
+repository = "https://github.com/divviup/libprio-rs"
+resolver = "2"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[[example]]
+name = "sum"
+required-features = ["prio2"]
+
+[[test]]
+name = "backward_compatibility"
+path = "tests/backward_compatibility.rs"
+required-features = ["prio2"]
+
+[[bench]]
+name = "speed_tests"
+harness = false
+
+[[bench]]
+name = "cycle_counts"
+harness = false
+
+[dependencies.aes]
+version = "0.8.1"
+optional = true
+
+[dependencies.aes-gcm]
+version = "^0.9"
+optional = true
+
+[dependencies.base64]
+version = "0.13.0"
+
+[dependencies.byteorder]
+version = "1.4.3"
+
+[dependencies.cmac]
+version = "0.7.1"
+optional = true
+
+[dependencies.ctr]
+version = "0.9.1"
+optional = true
+
+[dependencies.getrandom]
+version = "0.2.7"
+features = ["std"]
+
+[dependencies.rand]
+version = "0.8"
+optional = true
+
+[dependencies.rayon]
+version = "1.5.3"
+optional = true
+
+[dependencies.ring]
+version = "0.16.20"
+optional = true
+
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
+[dependencies.serde_json]
+version = "1.0"
+optional = true
+
+[dependencies.static_assertions]
+version = "1.1.0"
+
+[dependencies.thiserror]
+version = "1.0"
+
+[dev-dependencies.assert_matches]
+version = "1.5.0"
+
+[dev-dependencies.cfg-if]
+version = "1.0.0"
+
+[dev-dependencies.criterion]
+version = "0.4"
+
+[dev-dependencies.hex]
+version = "0.4.3"
+features = ["serde"]
+
+[dev-dependencies.iai]
+version = "0.1"
+
+[dev-dependencies.itertools]
+version = "0.10.3"
+
+[dev-dependencies.modinverse]
+version = "0.1.0"
+
+[dev-dependencies.num-bigint]
+version = "0.4.3"
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[features]
+crypto-dependencies = [
+ "aes",
+ "ctr",
+ "cmac",
+]
+default = ["crypto-dependencies"]
+multithreaded = ["rayon"]
+prio2 = [
+ "aes-gcm",
+ "ring",
+]
+test-util = [
+ "rand",
+ "serde_json",
+]