summaryrefslogtreecommitdiffstats
path: root/third_party/rust/scoped-tls/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/scoped-tls/README.md
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/scoped-tls/README.md')
-rw-r--r--third_party/rust/scoped-tls/README.md32
1 files changed, 32 insertions, 0 deletions
diff --git a/third_party/rust/scoped-tls/README.md b/third_party/rust/scoped-tls/README.md
new file mode 100644
index 0000000000..36e6480e2c
--- /dev/null
+++ b/third_party/rust/scoped-tls/README.md
@@ -0,0 +1,32 @@
+# scoped-tls
+
+[![Build Status](https://travis-ci.org/alexcrichton/scoped-tls.svg?branch=master)](https://travis-ci.org/alexcrichton/scoped-tls)
+[![Build status](https://ci.appveyor.com/api/projects/status/9tatexq47i3ee13k?svg=true)](https://ci.appveyor.com/project/alexcrichton/flate2-rs)
+
+[Documentation](https://docs.rs/scoped-tls)
+
+A Rust library providing the old standard library's `scoped_thread_local!` macro
+as a library implementation on crates.io.
+
+```toml
+# Cargo.toml
+[dependencies]
+scoped-tls = "1.0"
+```
+
+# License
+
+This project is licensed under either of
+
+ * Apache License, Version 2.0, ([LICENSE-APACHE](LICENSE-APACHE) or
+ http://www.apache.org/licenses/LICENSE-2.0)
+ * MIT license ([LICENSE-MIT](LICENSE-MIT) or
+ http://opensource.org/licenses/MIT)
+
+at your option.
+
+### Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally submitted
+for inclusion in Serde by you, as defined in the Apache-2.0 license, shall be
+dual licensed as above, without any additional terms or conditions.