summaryrefslogtreecommitdiffstats
path: root/third_party/rust/siphasher/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/siphasher/README.md
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/siphasher/README.md')
-rw-r--r--third_party/rust/siphasher/README.md43
1 files changed, 43 insertions, 0 deletions
diff --git a/third_party/rust/siphasher/README.md b/third_party/rust/siphasher/README.md
new file mode 100644
index 0000000000..58743ab721
--- /dev/null
+++ b/third_party/rust/siphasher/README.md
@@ -0,0 +1,43 @@
+SipHash implementation for Rust
+===============================
+
+This crates implements SipHash-2-4 and SipHash-1-3 in Rust.
+
+It is based on the original implementation from rust-core and exposes the
+same API.
+
+It also implements SipHash variants returning 128-bit tags.
+
+The `sip` module implements the standard 64-bit mode, whereas the `sip128`
+module implements the 128-bit mode.
+
+Usage
+-----
+In `Cargo.toml`:
+
+```toml
+[dependencies]
+siphasher = "0.3"
+```
+
+If you want [serde](https://github.com/serde-rs/serde) support, include the feature like this:
+
+```toml
+[dependencies]
+siphasher = { version = "0.3", features = ["serde"] }
+```
+
+64-bit mode:
+```rust
+extern crate siphasher;
+
+use siphasher::sip::{SipHasher, SipHasher13, SipHasher24};
+```
+
+128-bit mode:
+```rust
+use siphasher::sip128::{Hasher128, Siphasher, SipHasher13, SipHasher24};
+```
+
+[API documentation](https://docs.rs/siphasher/)
+-----------------------------------------------