summaryrefslogtreecommitdiffstats
path: root/third_party/rust/sync15/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/sync15/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-upstream.tar.xz
firefox-esr-upstream.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/sync15/Cargo.toml')
-rw-r--r--third_party/rust/sync15/Cargo.toml87
1 files changed, 87 insertions, 0 deletions
diff --git a/third_party/rust/sync15/Cargo.toml b/third_party/rust/sync15/Cargo.toml
new file mode 100644
index 0000000000..895a5c3816
--- /dev/null
+++ b/third_party/rust/sync15/Cargo.toml
@@ -0,0 +1,87 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "sync15"
+version = "0.1.0"
+authors = ["application-services@mozilla.com"]
+exclude = [
+ "/android",
+ "/ios",
+]
+readme = "README.md"
+license = "MPL-2.0"
+
+[dependencies]
+anyhow = "1.0"
+ffi-support = "0.4"
+lazy_static = "1.4"
+log = "0.4"
+serde_derive = "1"
+serde_json = "1"
+thiserror = "1.0"
+
+[dependencies.base16]
+version = "0.2"
+optional = true
+
+[dependencies.base64]
+version = "0.13"
+optional = true
+
+[dependencies.error-support]
+path = "../support/error"
+
+[dependencies.interrupt-support]
+path = "../support/interrupt"
+
+[dependencies.rc_crypto]
+path = "../support/rc_crypto"
+features = ["hawk"]
+optional = true
+
+[dependencies.serde]
+version = "1"
+features = ["derive"]
+
+[dependencies.sync-guid]
+path = "../support/guid"
+features = ["random"]
+
+[dependencies.url]
+version = "2.1"
+optional = true
+
+[dependencies.viaduct]
+path = "../viaduct"
+optional = true
+
+[dev-dependencies.env_logger]
+version = "0.7"
+default-features = false
+
+[features]
+crypto = [
+ "rc_crypto",
+ "base16",
+ "base64",
+]
+default = ["sync-engine"]
+random-guid = ["sync-guid/random"]
+standalone-sync = ["sync-client"]
+sync-client = [
+ "sync-engine",
+ "crypto",
+ "viaduct",
+ "url",
+]
+sync-engine = ["random-guid"]