summaryrefslogtreecommitdiffstats
path: root/third_party/rust/triple_buffer/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/triple_buffer/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/triple_buffer/Cargo.toml')
-rw-r--r--third_party/rust/triple_buffer/Cargo.toml43
1 files changed, 43 insertions, 0 deletions
diff --git a/third_party/rust/triple_buffer/Cargo.toml b/third_party/rust/triple_buffer/Cargo.toml
new file mode 100644
index 0000000000..a019221a03
--- /dev/null
+++ b/third_party/rust/triple_buffer/Cargo.toml
@@ -0,0 +1,43 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "triple_buffer"
+version = "5.0.6"
+authors = ["Hadrien G. <knights_of_ni@gmx.com>"]
+description = "An implementation of triple buffering, useful for sharing frequently updated data between threads"
+documentation = "https://docs.rs/triple_buffer/"
+readme = "README.md"
+keywords = ["synchronization", "spsc", "multithreading", "non-blocking", "wait-free"]
+categories = ["algorithms", "asynchronous", "concurrency", "data-structures"]
+license = "MPL-2.0"
+repository = "https://github.com/HadrienG2/triple-buffer"
+
+[lib]
+bench = false
+
+[[bench]]
+name = "benchmarks"
+harness = false
+[dependencies.cache-padded]
+version = "1.1"
+[dev-dependencies.criterion]
+version = "0.3"
+
+[dev-dependencies.testbench]
+version = "0.8"
+
+[features]
+raw = []
+[badges.maintenance]
+status = "passively-maintained"