summaryrefslogtreecommitdiffstats
path: root/third_party/rust/url/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/url/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-upstream.tar.xz
firefox-esr-upstream.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/url/Cargo.toml')
-rw-r--r--third_party/rust/url/Cargo.toml63
1 files changed, 63 insertions, 0 deletions
diff --git a/third_party/rust/url/Cargo.toml b/third_party/rust/url/Cargo.toml
new file mode 100644
index 0000000000..6a82c2b98a
--- /dev/null
+++ b/third_party/rust/url/Cargo.toml
@@ -0,0 +1,63 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "url"
+version = "2.1.0"
+authors = ["The rust-url developers"]
+description = "URL library for Rust, based on the WHATWG URL Standard"
+documentation = "https://docs.rs/url"
+readme = "README.md"
+keywords = ["url", "parser"]
+categories = ["parser-implementations", "web-programming", "encoding"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/servo/rust-url"
+
+[lib]
+test = false
+
+[[test]]
+name = "unit"
+
+[[test]]
+name = "data"
+harness = false
+
+[[bench]]
+name = "parse_url"
+harness = false
+[dependencies.idna]
+version = "0.2.0"
+
+[dependencies.matches]
+version = "0.1"
+
+[dependencies.percent-encoding]
+version = "2.0.0"
+
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+optional = true
+[dev-dependencies.bencher]
+version = "0.1"
+
+[dev-dependencies.rustc-test]
+version = "0.3"
+
+[dev-dependencies.serde_json]
+version = "1.0"
+[badges.appveyor]
+repository = "Manishearth/rust-url"
+
+[badges.travis-ci]
+repository = "servo/rust-url"