summaryrefslogtreecommitdiffstats
path: root/third_party/rust/wasm-smith/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/wasm-smith/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/wasm-smith/Cargo.toml')
-rw-r--r--third_party/rust/wasm-smith/Cargo.toml72
1 files changed, 72 insertions, 0 deletions
diff --git a/third_party/rust/wasm-smith/Cargo.toml b/third_party/rust/wasm-smith/Cargo.toml
new file mode 100644
index 0000000000..06606c0147
--- /dev/null
+++ b/third_party/rust/wasm-smith/Cargo.toml
@@ -0,0 +1,72 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "wasm-smith"
+version = "0.12.5"
+authors = ["Nick Fitzgerald <fitzgen@gmail.com>"]
+exclude = ["/benches/corpus"]
+description = "A WebAssembly test case generator"
+documentation = "https://docs.rs/wasm-smith"
+readme = "./README.md"
+categories = [
+ "command-line-utilities",
+ "development-tools",
+ "development-tools::testing",
+ "wasm",
+]
+license = "Apache-2.0 WITH LLVM-exception"
+repository = "https://github.com/bytecodealliance/wasm-tools/tree/main/crates/wasm-smith"
+
+[[bench]]
+name = "corpus"
+harness = false
+
+[dependencies.arbitrary]
+version = "1.1.0"
+features = ["derive"]
+
+[dependencies.flagset]
+version = "0.4"
+
+[dependencies.indexmap]
+version = "1.9.1"
+
+[dependencies.leb128]
+version = "0.2.4"
+
+[dependencies.serde]
+version = "1.0.137"
+features = ["derive"]
+optional = true
+
+[dependencies.wasm-encoder]
+version = "0.25.0"
+
+[dependencies.wasmparser]
+version = "0.102.0"
+
+[dev-dependencies.criterion]
+version = "0.3.3"
+
+[dev-dependencies.libfuzzer-sys]
+version = "0.4.0"
+
+[dev-dependencies.rand]
+version = "0.8.4"
+features = ["small_rng"]
+
+[features]
+_internal_cli = [
+ "serde",
+ "flagset/serde",
+]