summaryrefslogtreecommitdiffstats
path: root/third_party/rust/weedle2/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/weedle2/README.md
parentInitial commit. (diff)
downloadfirefox-esr-upstream.tar.xz
firefox-esr-upstream.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/weedle2/README.md')
-rw-r--r--third_party/rust/weedle2/README.md46
1 files changed, 46 insertions, 0 deletions
diff --git a/third_party/rust/weedle2/README.md b/third_party/rust/weedle2/README.md
new file mode 100644
index 0000000000..889dc0da19
--- /dev/null
+++ b/third_party/rust/weedle2/README.md
@@ -0,0 +1,46 @@
+<div align="center">
+
+ <h1>Weedle 2 - Electric Boogaloo</h1>
+
+ <strong>A Web IDL parser</strong>
+
+ <p>
+ <a href="https://crates.io/crates/weedle2"><img src="https://img.shields.io/crates/v/weedle2.svg?style=flat-square" alt="Crates.io version" /></a>
+ <a href="https://docs.rs/weedle2"><img src="https://img.shields.io/badge/docs-latest-blue.svg?style=flat-square" alt="Documentation" /></a>
+ <a href="LICENSE"><img src="https://img.shields.io/crates/l/weedle2/2.0.0?style=flat-square" alt="MIT License" /></a>
+ </p>
+
+ <sub>
+ Built with 🦀🕸 by <a href="https://rustwasm.github.io/">The Rust and WebAssembly Working Group</a>.
+ <br>
+ Forked to extend the functionality beyond WebIDL needs.
+ </sub>
+</div>
+
+## About
+
+Parses valid WebIDL definitions & produces a data structure starting from
+[`Definitions`](https://docs.rs/weedle/latest/weedle/type.Definitions.html).
+
+## Usage
+
+### `Cargo.toml`
+
+```toml
+[dependencies]
+weedle2 = "4.0.0"
+```
+
+### `src/main.rs`
+
+```rust
+fn main() {
+ let parsed = weedle::parse("
+ interface Window {
+ readonly attribute Storage sessionStorage;
+ };
+ ").unwrap();
+
+ println!("{:?}", parsed);
+}
+```