summaryrefslogtreecommitdiffstats
path: root/third_party/rust/winreg/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/winreg/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/winreg/Cargo.toml')
-rw-r--r--third_party/rust/winreg/Cargo.toml75
1 files changed, 75 insertions, 0 deletions
diff --git a/third_party/rust/winreg/Cargo.toml b/third_party/rust/winreg/Cargo.toml
new file mode 100644
index 0000000000..adb2e88655
--- /dev/null
+++ b/third_party/rust/winreg/Cargo.toml
@@ -0,0 +1,75 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "winreg"
+version = "0.10.1"
+authors = ["Igor Shaula <gentoo90@gmail.com>"]
+description = "Rust bindings to MS Windows Registry API"
+documentation = "https://docs.rs/winreg"
+readme = "README.md"
+keywords = ["Windows", "WinSDK", "Registry"]
+categories = ["api-bindings", "os::windows-apis"]
+license = "MIT"
+repository = "https://github.com/gentoo90/winreg-rs"
+[package.metadata.docs.rs]
+all-features = true
+targets = ["x86_64-pc-windows-msvc", "i686-pc-windows-msvc"]
+
+[[example]]
+name = "basic_usage"
+required-features = ["chrono"]
+
+[[example]]
+name = "enum"
+
+[[example]]
+name = "load_app_key"
+
+[[example]]
+name = "transactions"
+required-features = ["transactions"]
+
+[[example]]
+name = "serialization"
+required-features = ["serialization-serde"]
+
+[[example]]
+name = "map_key_serialization"
+required-features = ["serialization-serde"]
+
+[[example]]
+name = "installed_apps"
+required-features = ["serialization-serde"]
+[dependencies.chrono]
+version = "0.4.6"
+optional = true
+
+[dependencies.serde]
+version = "1"
+optional = true
+
+[dependencies.winapi]
+version = "0.3.9"
+features = ["impl-default", "impl-debug", "minwindef", "minwinbase", "timezoneapi", "winerror", "winnt", "winreg", "handleapi"]
+[dev-dependencies.rand]
+version = "0.3"
+
+[dev-dependencies.serde_derive]
+version = "1"
+
+[dev-dependencies.tempfile]
+version = "~3.0"
+
+[features]
+serialization-serde = ["transactions", "serde"]
+transactions = ["winapi/ktmw32"]