summaryrefslogtreecommitdiffstats
path: root/toolkit/locales/Makefile.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /toolkit/locales/Makefile.in
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esrupstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'toolkit/locales/Makefile.in')
-rw-r--r--toolkit/locales/Makefile.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/toolkit/locales/Makefile.in b/toolkit/locales/Makefile.in
new file mode 100644
index 0000000000..428596223e
--- /dev/null
+++ b/toolkit/locales/Makefile.in
@@ -0,0 +1,22 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+include $(topsrcdir)/config/rules.mk
+
+l10n-%: AB_CD=$*
+l10n-%:
+ @$(MAKE) -C ../../netwerk/locales/ l10n AB_CD=$* XPI_NAME=locale-$*
+ @$(MAKE) -C ../../dom/locales/ l10n AB_CD=$* XPI_NAME=locale-$*
+ @$(MAKE) -C ../../security/manager/locales/ l10n AB_CD=$* XPI_NAME=locale-$*
+ @$(MAKE) -C ../../devtools/shared/locales/ l10n AB_CD=$* XPI_NAME=locale-$*
+ @$(MAKE) l10n AB_CD=$* XPI_NAME=locale-$*
+
+# target to be used by multi-locale l10n builds, just add this locale
+# like regular chrome code
+chrome-%: AB_CD=$*
+chrome-%:
+ @$(MAKE) -C $(DEPTH)/netwerk/locales/ chrome AB_CD=$*
+ @$(MAKE) -C $(DEPTH)/dom/locales/ chrome AB_CD=$*
+ @$(MAKE) -C $(DEPTH)/security/manager/locales/ chrome AB_CD=$*
+ @$(MAKE) chrome AB_CD=$*