summaryrefslogtreecommitdiffstats
path: root/config/external/zlib/moz.build
diff options
context:
space:
mode:
Diffstat (limited to 'config/external/zlib/moz.build')
-rw-r--r--config/external/zlib/moz.build21
1 files changed, 21 insertions, 0 deletions
diff --git a/config/external/zlib/moz.build b/config/external/zlib/moz.build
new file mode 100644
index 0000000000..755400fa7f
--- /dev/null
+++ b/config/external/zlib/moz.build
@@ -0,0 +1,21 @@
+# -*- Mode: python; indent-tabs-mode: nil; tab-width: 40 -*-
+# vim: set filetype=python:
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+Library("zlib")
+
+if CONFIG["MOZ_SYSTEM_ZLIB"]:
+ OS_LIBS += CONFIG["MOZ_ZLIB_LIBS"]
+else:
+ if CONFIG["ZLIB_IN_MOZGLUE"]:
+ # Can't do this until mozglue is handled by moz.build instead of
+ # config/rules.mk.
+ # USE_LIBS += [
+ # 'mozglue'
+ # ]
+ pass
+ DIRS += [
+ "../../../modules/zlib",
+ ]