summaryrefslogtreecommitdiffstats
path: root/debian/dh
diff options
context:
space:
mode:
Diffstat (limited to 'debian/dh')
-rwxr-xr-xdebian/dh25
1 files changed, 25 insertions, 0 deletions
diff --git a/debian/dh b/debian/dh
new file mode 100755
index 0000000000..5b43536dd4
--- /dev/null
+++ b/debian/dh
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+# Wrapper around dh to enable parallelism in debian/rules if not already
+# enabled.
+
+case "$MAKEFLAGS" in
+*-j*)
+ # Already enabled, do nothing.
+ ;;
+*)
+ parallel=
+ for opt in "$DEB_BUILD_OPTIONS"; do
+ case "$opt" in
+ parallel=*)
+ parallel=${opt#parallel=}
+ ;;
+ esac
+ done
+ if [ -n "$parallel" ]; then
+ export MAKEFLAGS="-j$parallel${MAKEFLAGS:+ $MAKEFLAGS}"
+ fi
+ ;;
+esac
+
+exec dh "$@"