summaryrefslogtreecommitdiffstats
path: root/dom/webgpu/tests/cts/checkout/src/demo/subcases.spec.ts
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webgpu/tests/cts/checkout/src/demo/subcases.spec.ts')
-rw-r--r--dom/webgpu/tests/cts/checkout/src/demo/subcases.spec.ts38
1 files changed, 38 insertions, 0 deletions
diff --git a/dom/webgpu/tests/cts/checkout/src/demo/subcases.spec.ts b/dom/webgpu/tests/cts/checkout/src/demo/subcases.spec.ts
new file mode 100644
index 0000000000..6b22463f07
--- /dev/null
+++ b/dom/webgpu/tests/cts/checkout/src/demo/subcases.spec.ts
@@ -0,0 +1,38 @@
+export const description = 'Tests with subcases';
+
+import { makeTestGroup } from '../common/framework/test_group.js';
+import { UnitTest } from '../unittests/unit_test.js';
+
+export const g = makeTestGroup(UnitTest);
+
+g.test('pass_warn_fail')
+ .params(u =>
+ u
+ .combine('x', [1, 2, 3]) //
+ .beginSubcases()
+ .combine('y', [1, 2, 3])
+ )
+ .fn(t => {
+ const { x, y } = t.params;
+ if (x + y > 5) {
+ t.fail();
+ } else if (x + y > 4) {
+ t.warn();
+ }
+ });
+
+g.test('DOMException,cases')
+ .params(u => u.combine('fail', [false, true]))
+ .fn(t => {
+ if (t.params.fail) {
+ throw new DOMException('Message!', 'Name!');
+ }
+ });
+
+g.test('DOMException,subcases')
+ .paramsSubcasesOnly(u => u.combine('fail', [false, true]))
+ .fn(t => {
+ if (t.params.fail) {
+ throw new DOMException('Message!', 'Name!');
+ }
+ });