summaryrefslogtreecommitdiffstats
path: root/dom/webgpu/tests/cts/checkout/tsconfig.json
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webgpu/tests/cts/checkout/tsconfig.json')
-rw-r--r--dom/webgpu/tests/cts/checkout/tsconfig.json49
1 files changed, 49 insertions, 0 deletions
diff --git a/dom/webgpu/tests/cts/checkout/tsconfig.json b/dom/webgpu/tests/cts/checkout/tsconfig.json
new file mode 100644
index 0000000000..2b60900598
--- /dev/null
+++ b/dom/webgpu/tests/cts/checkout/tsconfig.json
@@ -0,0 +1,49 @@
+{
+ "extends": "./node_modules/gts/tsconfig-google.json",
+ "compilerOptions": {
+ "lib": ["dom", "es2019"],
+ "module": "esnext",
+ /* Output options */
+ "noEmit": true,
+ /* Strict type-checking options */
+ "allowJs": true,
+ "strict": true,
+ /* tsc lint options */
+ "noImplicitReturns": true,
+ /* These should be caught by eslint instead */
+ "noFallthroughCasesInSwitch": false,
+ "noUnusedLocals": false,
+ "allowUnreachableCode": true,
+ /* Module Options */
+ "moduleResolution": "node",
+ "esModuleInterop": false,
+ "skipLibCheck": true,
+ },
+ "include": [
+ "src/**/*.ts",
+ "src/external/**/*.js",
+ ],
+ "typedocOptions": {
+ "entryPointStrategy": "expand",
+ "entryPoints": [
+ "src/common/framework/",
+ "src/common/util/",
+ "src/webgpu/",
+ ],
+ "exclude": [
+ "**/*.spec.ts",
+ "**/*.html.ts",
+ "src/*/listing.ts",
+ "src/webgpu/util/device_pool.ts",
+ ],
+ "excludeInternal": true,
+ "excludeProtected": true,
+ "excludePrivate": true,
+ "validation": {
+ "invalidLink": true,
+ "notExported": false,
+ },
+ "readme": "./docs/helper_index.txt",
+ "out": "docs/tsdoc/"
+ }
+}