summaryrefslogtreecommitdiffstats
path: root/dom/webidl/AbortController.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/AbortController.webidl')
-rw-r--r--dom/webidl/AbortController.webidl18
1 files changed, 18 insertions, 0 deletions
diff --git a/dom/webidl/AbortController.webidl b/dom/webidl/AbortController.webidl
new file mode 100644
index 0000000000..2b172b7718
--- /dev/null
+++ b/dom/webidl/AbortController.webidl
@@ -0,0 +1,18 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://dom.spec.whatwg.org/#abortcontroller
+ */
+
+[Exposed=(Window,Worker)]
+interface AbortController {
+ [Throws]
+ constructor();
+
+ [SameObject] readonly attribute AbortSignal signal;
+
+ undefined abort(optional any reason);
+};