summaryrefslogtreecommitdiffstats
path: root/dom/webidl/AbortSignal.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/AbortSignal.webidl')
-rw-r--r--dom/webidl/AbortSignal.webidl21
1 files changed, 21 insertions, 0 deletions
diff --git a/dom/webidl/AbortSignal.webidl b/dom/webidl/AbortSignal.webidl
new file mode 100644
index 0000000000..5a87bc482c
--- /dev/null
+++ b/dom/webidl/AbortSignal.webidl
@@ -0,0 +1,21 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://dom.spec.whatwg.org/#abortsignal
+ */
+
+[Exposed=*]
+interface AbortSignal : EventTarget {
+ [NewObject] static AbortSignal abort(optional any reason);
+ [Exposed=(Window,Worker), NewObject, Throws]
+ static AbortSignal timeout([EnforceRange] unsigned long long milliseconds);
+
+ readonly attribute boolean aborted;
+ readonly attribute any reason;
+ [Throws] undefined throwIfAborted();
+
+ attribute EventHandler onabort;
+};