summaryrefslogtreecommitdiffstats
path: root/dom/webidl/AnimationFrameProvider.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/AnimationFrameProvider.webidl')
-rw-r--r--dom/webidl/AnimationFrameProvider.webidl15
1 files changed, 15 insertions, 0 deletions
diff --git a/dom/webidl/AnimationFrameProvider.webidl b/dom/webidl/AnimationFrameProvider.webidl
new file mode 100644
index 0000000000..2932698c3b
--- /dev/null
+++ b/dom/webidl/AnimationFrameProvider.webidl
@@ -0,0 +1,15 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://html.spec.whatwg.org/multipage/imagebitmap-and-animations.html#animation-frames
+ */
+
+callback FrameRequestCallback = undefined (DOMHighResTimeStamp time);
+
+interface mixin AnimationFrameProvider {
+ [Throws] long requestAnimationFrame(FrameRequestCallback callback);
+ [Throws] undefined cancelAnimationFrame(long handle);
+};