summaryrefslogtreecommitdiffstats
path: root/dom/webidl/BroadcastChannel.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/BroadcastChannel.webidl')
-rw-r--r--dom/webidl/BroadcastChannel.webidl24
1 files changed, 24 insertions, 0 deletions
diff --git a/dom/webidl/BroadcastChannel.webidl b/dom/webidl/BroadcastChannel.webidl
new file mode 100644
index 0000000000..196ff2eff9
--- /dev/null
+++ b/dom/webidl/BroadcastChannel.webidl
@@ -0,0 +1,24 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * For more information on this interface, please see
+ * https://html.spec.whatwg.org/#broadcastchannel
+ */
+
+[Exposed=(Window,Worker)]
+interface BroadcastChannel : EventTarget {
+ [Throws]
+ constructor(DOMString channel);
+
+ readonly attribute DOMString name;
+
+ [Throws]
+ undefined postMessage(any message);
+
+ undefined close();
+
+ attribute EventHandler onmessage;
+ attribute EventHandler onmessageerror;
+};