summaryrefslogtreecommitdiffstats
path: root/dom/webidl/CharacterData.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/CharacterData.webidl')
-rw-r--r--dom/webidl/CharacterData.webidl32
1 files changed, 32 insertions, 0 deletions
diff --git a/dom/webidl/CharacterData.webidl b/dom/webidl/CharacterData.webidl
new file mode 100644
index 0000000000..6b447af94b
--- /dev/null
+++ b/dom/webidl/CharacterData.webidl
@@ -0,0 +1,32 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * http://dom.spec.whatwg.org/#characterdata
+ *
+ * Copyright © 2012 W3C® (MIT, ERCIM, Keio), All Rights Reserved. W3C
+ * liability, trademark and document use rules apply.
+ */
+
+[Exposed=Window]
+interface CharacterData : Node {
+ [Pure, SetterThrows]
+ attribute [LegacyNullToEmptyString] DOMString data;
+ [Pure]
+ readonly attribute unsigned long length;
+ [Throws]
+ DOMString substringData(unsigned long offset, unsigned long count);
+ [Throws]
+ undefined appendData(DOMString data);
+ [Throws]
+ undefined insertData(unsigned long offset, DOMString data);
+ [Throws]
+ undefined deleteData(unsigned long offset, unsigned long count);
+ [Throws]
+ undefined replaceData(unsigned long offset, unsigned long count, DOMString data);
+};
+
+CharacterData includes ChildNode;
+CharacterData includes NonDocumentTypeChildNode;