summaryrefslogtreecommitdiffstats
path: root/dom/webidl/FormData.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/FormData.webidl')
-rw-r--r--dom/webidl/FormData.webidl30
1 files changed, 30 insertions, 0 deletions
diff --git a/dom/webidl/FormData.webidl b/dom/webidl/FormData.webidl
new file mode 100644
index 0000000000..360b03aea4
--- /dev/null
+++ b/dom/webidl/FormData.webidl
@@ -0,0 +1,30 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * http://xhr.spec.whatwg.org
+ */
+
+typedef (Blob or Directory or USVString) FormDataEntryValue;
+
+[Exposed=(Window,Worker)]
+interface FormData {
+ [Throws]
+ constructor(optional HTMLFormElement form, optional HTMLElement? submitter = null);
+
+ [Throws]
+ undefined append(USVString name, Blob value, optional USVString filename);
+ [Throws]
+ undefined append(USVString name, USVString value);
+ undefined delete(USVString name);
+ FormDataEntryValue? get(USVString name);
+ sequence<FormDataEntryValue> getAll(USVString name);
+ boolean has(USVString name);
+ [Throws]
+ undefined set(USVString name, Blob value, optional USVString filename);
+ [Throws]
+ undefined set(USVString name, USVString value);
+ iterable<USVString, FormDataEntryValue>;
+};