summaryrefslogtreecommitdiffstats
path: root/dom/webidl/GenericTransformStream.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/GenericTransformStream.webidl')
-rw-r--r--dom/webidl/GenericTransformStream.webidl13
1 files changed, 13 insertions, 0 deletions
diff --git a/dom/webidl/GenericTransformStream.webidl b/dom/webidl/GenericTransformStream.webidl
new file mode 100644
index 0000000000..cc54b361fc
--- /dev/null
+++ b/dom/webidl/GenericTransformStream.webidl
@@ -0,0 +1,13 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://streams.spec.whatwg.org/#other-specs-ts-wrapping
+ */
+
+interface mixin GenericTransformStream {
+ readonly attribute ReadableStream readable;
+ readonly attribute WritableStream writable;
+};