summaryrefslogtreecommitdiffstats
path: root/dom/webidl/HTMLDetailsElement.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/HTMLDetailsElement.webidl')
-rw-r--r--dom/webidl/HTMLDetailsElement.webidl20
1 files changed, 20 insertions, 0 deletions
diff --git a/dom/webidl/HTMLDetailsElement.webidl b/dom/webidl/HTMLDetailsElement.webidl
new file mode 100644
index 0000000000..7f293f8ed8
--- /dev/null
+++ b/dom/webidl/HTMLDetailsElement.webidl
@@ -0,0 +1,20 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://html.spec.whatwg.org/multipage/forms.html#the-details-element
+ *
+ * © Copyright 2004-2011 Apple Computer, Inc., Mozilla Foundation, and
+ * Opera Software ASA. You are granted a license to use, reproduce
+ * and create derivative works of this document.
+ */
+
+[Exposed=Window]
+interface HTMLDetailsElement : HTMLElement {
+ [HTMLConstructor] constructor();
+
+ [CEReactions, SetterThrows]
+ attribute boolean open;
+};