summaryrefslogtreecommitdiffstats
path: root/dom/webidl/HTMLDialogElement.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/HTMLDialogElement.webidl')
-rw-r--r--dom/webidl/HTMLDialogElement.webidl28
1 files changed, 28 insertions, 0 deletions
diff --git a/dom/webidl/HTMLDialogElement.webidl b/dom/webidl/HTMLDialogElement.webidl
new file mode 100644
index 0000000000..5a355c023e
--- /dev/null
+++ b/dom/webidl/HTMLDialogElement.webidl
@@ -0,0 +1,28 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://html.spec.whatwg.org/multipage/forms.html#the-dialog-element
+ *
+ * © Copyright 2004-2011 Apple Computer, Inc., Mozilla Foundation, and
+ * Opera Software ASA. You are granted a license to use, reproduce
+ * and create derivative works of this document.
+ */
+
+[Func="mozilla::dom::HTMLDialogElement::IsDialogEnabled",
+ Exposed=Window]
+interface HTMLDialogElement : HTMLElement {
+ [HTMLConstructor] constructor();
+
+ [CEReactions, SetterThrows]
+ attribute boolean open;
+ attribute DOMString returnValue;
+ [CEReactions, Throws]
+ undefined show();
+ [CEReactions, Throws]
+ undefined showModal();
+ [CEReactions]
+ undefined close(optional DOMString returnValue);
+};