summaryrefslogtreecommitdiffstats
path: root/dom/webidl/HTMLHyperlinkElementUtils.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/HTMLHyperlinkElementUtils.webidl')
-rw-r--r--dom/webidl/HTMLHyperlinkElementUtils.webidl36
1 files changed, 36 insertions, 0 deletions
diff --git a/dom/webidl/HTMLHyperlinkElementUtils.webidl b/dom/webidl/HTMLHyperlinkElementUtils.webidl
new file mode 100644
index 0000000000..652437c81b
--- /dev/null
+++ b/dom/webidl/HTMLHyperlinkElementUtils.webidl
@@ -0,0 +1,36 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://html.spec.whatwg.org/multipage/semantics.html#htmlhyperlinkelementutils
+ * © Copyright 2004-2011 Apple Computer, Inc., Mozilla Foundation, and
+ * Opera Software ASA. You are granted a license to use, reproduce
+ * and create derivative works of this document.
+ */
+
+interface mixin HTMLHyperlinkElementUtils {
+ [CEReactions, SetterThrows]
+ stringifier attribute USVString href;
+
+ readonly attribute USVString origin;
+ [CEReactions]
+ attribute USVString protocol;
+ [CEReactions]
+ attribute USVString username;
+ [CEReactions]
+ attribute USVString password;
+ [CEReactions]
+ attribute USVString host;
+ [CEReactions]
+ attribute USVString hostname;
+ [CEReactions]
+ attribute USVString port;
+ [CEReactions]
+ attribute USVString pathname;
+ [CEReactions]
+ attribute USVString search;
+ [CEReactions]
+ attribute USVString hash;
+};