summaryrefslogtreecommitdiffstats
path: root/dom/webidl/HashChangeEvent.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/HashChangeEvent.webidl')
-rw-r--r--dom/webidl/HashChangeEvent.webidl30
1 files changed, 30 insertions, 0 deletions
diff --git a/dom/webidl/HashChangeEvent.webidl b/dom/webidl/HashChangeEvent.webidl
new file mode 100644
index 0000000000..0a99a41018
--- /dev/null
+++ b/dom/webidl/HashChangeEvent.webidl
@@ -0,0 +1,30 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://html.spec.whatwg.org/multipage/#the-hashchangeevent-interface
+ */
+
+[LegacyEventInit,
+ Exposed=Window]
+interface HashChangeEvent : Event
+{
+ constructor(DOMString type, optional HashChangeEventInit eventInitDict = {});
+
+ readonly attribute DOMString oldURL;
+ readonly attribute DOMString newURL;
+
+ undefined initHashChangeEvent(DOMString typeArg,
+ optional boolean canBubbleArg = false,
+ optional boolean cancelableArg = false,
+ optional DOMString oldURLArg = "",
+ optional DOMString newURLArg = "");
+};
+
+dictionary HashChangeEventInit : EventInit
+{
+ DOMString oldURL = "";
+ DOMString newURL = "";
+};