summaryrefslogtreecommitdiffstats
path: root/dom/webidl/ReadableStreamBYOBReader.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/ReadableStreamBYOBReader.webidl')
-rw-r--r--dom/webidl/ReadableStreamBYOBReader.webidl21
1 files changed, 21 insertions, 0 deletions
diff --git a/dom/webidl/ReadableStreamBYOBReader.webidl b/dom/webidl/ReadableStreamBYOBReader.webidl
new file mode 100644
index 0000000000..d19167b4ad
--- /dev/null
+++ b/dom/webidl/ReadableStreamBYOBReader.webidl
@@ -0,0 +1,21 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://streams.spec.whatwg.org/#byob-reader-class-definition
+ */
+
+[Exposed=*]
+interface ReadableStreamBYOBReader {
+ [Throws]
+ constructor(ReadableStream stream);
+
+ [NewObject]
+ Promise<ReadableStreamReadResult> read(ArrayBufferView view);
+
+ [Throws]
+ undefined releaseLock();
+};
+ReadableStreamBYOBReader includes ReadableStreamGenericReader;