summaryrefslogtreecommitdiffstats
path: root/dom/webidl/ReadableStreamBYOBRequest.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/ReadableStreamBYOBRequest.webidl')
-rw-r--r--dom/webidl/ReadableStreamBYOBRequest.webidl19
1 files changed, 19 insertions, 0 deletions
diff --git a/dom/webidl/ReadableStreamBYOBRequest.webidl b/dom/webidl/ReadableStreamBYOBRequest.webidl
new file mode 100644
index 0000000000..cc9a6b0f44
--- /dev/null
+++ b/dom/webidl/ReadableStreamBYOBRequest.webidl
@@ -0,0 +1,19 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://streams.spec.whatwg.org/#rs-byob-request-class-definition
+ */
+
+[Exposed=*]
+interface ReadableStreamBYOBRequest {
+ readonly attribute ArrayBufferView? view;
+
+ [Throws]
+ undefined respond([EnforceRange] unsigned long long bytesWritten);
+
+ [Throws]
+ undefined respondWithNewView(ArrayBufferView view);
+};