summaryrefslogtreecommitdiffstats
path: root/dom/webidl/TextDecoder.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/TextDecoder.webidl')
-rw-r--r--dom/webidl/TextDecoder.webidl37
1 files changed, 37 insertions, 0 deletions
diff --git a/dom/webidl/TextDecoder.webidl b/dom/webidl/TextDecoder.webidl
new file mode 100644
index 0000000000..fc01d7c8f7
--- /dev/null
+++ b/dom/webidl/TextDecoder.webidl
@@ -0,0 +1,37 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * http://encoding.spec.whatwg.org/#interface-textdecoder
+ */
+
+interface mixin TextDecoderCommon {
+ [Constant]
+ readonly attribute DOMString encoding;
+ [Constant]
+ readonly attribute boolean fatal;
+ [Constant]
+ readonly attribute boolean ignoreBOM;
+};
+
+[Exposed=(Window,Worker)]
+interface TextDecoder {
+ [Throws]
+ constructor(optional DOMString label = "utf-8",
+ optional TextDecoderOptions options = {});
+
+ [Throws]
+ USVString decode(optional BufferSource input, optional TextDecodeOptions options = {});
+};
+TextDecoder includes TextDecoderCommon;
+
+dictionary TextDecoderOptions {
+ boolean fatal = false;
+ boolean ignoreBOM = false;
+};
+
+dictionary TextDecodeOptions {
+ boolean stream = false;
+};