summaryrefslogtreecommitdiffstats
path: root/dom/webidl/TextEncoderStream.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/TextEncoderStream.webidl')
-rw-r--r--dom/webidl/TextEncoderStream.webidl16
1 files changed, 16 insertions, 0 deletions
diff --git a/dom/webidl/TextEncoderStream.webidl b/dom/webidl/TextEncoderStream.webidl
new file mode 100644
index 0000000000..2d9b8ad22d
--- /dev/null
+++ b/dom/webidl/TextEncoderStream.webidl
@@ -0,0 +1,16 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * http://encoding.spec.whatwg.org/#interface-textdecoderstream
+ */
+
+[Exposed=*]
+interface TextEncoderStream {
+ [Throws]
+ constructor();
+};
+TextEncoderStream includes TextEncoderCommon;
+TextEncoderStream includes GenericTransformStream;