summaryrefslogtreecommitdiffstats
path: root/dom/webidl/TextTrackCue.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/TextTrackCue.webidl')
-rw-r--r--dom/webidl/TextTrackCue.webidl21
1 files changed, 21 insertions, 0 deletions
diff --git a/dom/webidl/TextTrackCue.webidl b/dom/webidl/TextTrackCue.webidl
new file mode 100644
index 0000000000..444d470bbd
--- /dev/null
+++ b/dom/webidl/TextTrackCue.webidl
@@ -0,0 +1,21 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://html.spec.whatwg.org/#texttrackcue
+ */
+
+[Exposed=Window]
+interface TextTrackCue : EventTarget {
+ readonly attribute TextTrack? track;
+
+ attribute DOMString id;
+ attribute double startTime;
+ attribute double endTime;
+ attribute boolean pauseOnExit;
+
+ attribute EventHandler onenter;
+ attribute EventHandler onexit;
+};