summaryrefslogtreecommitdiffstats
path: root/dom/webidl/ToggleEvent.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/ToggleEvent.webidl')
-rw-r--r--dom/webidl/ToggleEvent.webidl21
1 files changed, 21 insertions, 0 deletions
diff --git a/dom/webidl/ToggleEvent.webidl b/dom/webidl/ToggleEvent.webidl
new file mode 100644
index 0000000000..42204bdc3a
--- /dev/null
+++ b/dom/webidl/ToggleEvent.webidl
@@ -0,0 +1,21 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://html.spec.whatwg.org/multipage/popover.html#the-toggleevent-interface
+ */
+
+[Pref="dom.element.popover.enabled",
+ Exposed=Window]
+interface ToggleEvent : Event {
+ constructor(DOMString type, optional ToggleEventInit eventInitDict = {});
+ readonly attribute DOMString oldState;
+ readonly attribute DOMString newState;
+};
+
+dictionary ToggleEventInit : EventInit {
+ DOMString oldState = "";
+ DOMString newState = "";
+};