summaryrefslogtreecommitdiffstats
path: root/dom/webidl/TransformStream.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/TransformStream.webidl')
-rw-r--r--dom/webidl/TransformStream.webidl19
1 files changed, 19 insertions, 0 deletions
diff --git a/dom/webidl/TransformStream.webidl b/dom/webidl/TransformStream.webidl
new file mode 100644
index 0000000000..3dcc74eedd
--- /dev/null
+++ b/dom/webidl/TransformStream.webidl
@@ -0,0 +1,19 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://streams.spec.whatwg.org/#ts-class-definition
+ */
+
+[Exposed=*] // [Transferable] - See Bug 1562065
+interface TransformStream {
+ [Throws]
+ constructor(optional object transformer,
+ optional QueuingStrategy writableStrategy = {},
+ optional QueuingStrategy readableStrategy = {});
+
+ readonly attribute ReadableStream readable;
+ readonly attribute WritableStream writable;
+};