summaryrefslogtreecommitdiffstats
path: root/dom/webidl/URLSearchParams.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/URLSearchParams.webidl')
-rw-r--r--dom/webidl/URLSearchParams.webidl37
1 files changed, 37 insertions, 0 deletions
diff --git a/dom/webidl/URLSearchParams.webidl b/dom/webidl/URLSearchParams.webidl
new file mode 100644
index 0000000000..4bd473d62a
--- /dev/null
+++ b/dom/webidl/URLSearchParams.webidl
@@ -0,0 +1,37 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * http://url.spec.whatwg.org/#urlsearchparams
+ *
+ * To the extent possible under law, the editors have waived all copyright
+ * and related or neighboring rights to this work. In addition, as of 17
+ * February 2013, the editors have made this specification available under
+ * the Open Web Foundation Agreement Version 1.0, which is available at
+ * http://www.openwebfoundation.org/legal/the-owf-1-0-agreements/owfa-1-0.
+ */
+
+[Exposed=(Window,Worker,WorkerDebugger),
+ Serializable]
+interface URLSearchParams {
+ [Throws]
+ constructor(optional (sequence<sequence<USVString>> or
+ record<USVString, USVString> or USVString) init = "");
+
+ readonly attribute unsigned long size;
+
+ undefined append(USVString name, USVString value);
+ undefined delete(USVString name, optional USVString value);
+ USVString? get(USVString name);
+ sequence<USVString> getAll(USVString name);
+ boolean has(USVString name, optional USVString value);
+ undefined set(USVString name, USVString value);
+
+ [Throws]
+ undefined sort();
+
+ iterable<USVString, USVString>;
+ stringifier;
+};