summaryrefslogtreecommitdiffstats
path: root/dom/webidl/WritableStreamDefaultController.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/WritableStreamDefaultController.webidl')
-rw-r--r--dom/webidl/WritableStreamDefaultController.webidl15
1 files changed, 15 insertions, 0 deletions
diff --git a/dom/webidl/WritableStreamDefaultController.webidl b/dom/webidl/WritableStreamDefaultController.webidl
new file mode 100644
index 0000000000..70a8812285
--- /dev/null
+++ b/dom/webidl/WritableStreamDefaultController.webidl
@@ -0,0 +1,15 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://streams.spec.whatwg.org/#ws-default-controller-class-definition
+ */
+
+[Exposed=*]
+interface WritableStreamDefaultController {
+ readonly attribute AbortSignal signal;
+ [Throws]
+ undefined error(optional any e);
+};