summaryrefslogtreecommitdiffstats
path: root/js/src/jit-test/etc/wasm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'js/src/jit-test/etc/wasm/Makefile')
-rw-r--r--js/src/jit-test/etc/wasm/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/js/src/jit-test/etc/wasm/Makefile b/js/src/jit-test/etc/wasm/Makefile
new file mode 100644
index 0000000000..c659a7000e
--- /dev/null
+++ b/js/src/jit-test/etc/wasm/Makefile
@@ -0,0 +1,10 @@
+.PHONY: update
+
+warning = '\# Wasm Spec Tests\n\nThese tests are autogenerated using a tool, do not edit.\n\nSee `jit-test/etc/wasm/` for more information.'
+
+update:
+ (cd ./generate-spectests && RUST_BACKTRACE=1 RUST_LOG=info cargo run --release)
+ rm -r ../../tests/wasm/spec
+ cp -R generate-spectests/tests/js ../../tests/wasm/spec
+ echo $(warning) > ../../tests/wasm/spec/README.md
+ [ -f ./spec-tests.patch ] && (cd ../../tests/wasm/spec && patch -u -p7 < ../../../etc/wasm/spec-tests.patch)