summaryrefslogtreecommitdiffstats
path: root/js/src/rust/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'js/src/rust/Cargo.toml')
-rw-r--r--js/src/rust/Cargo.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/js/src/rust/Cargo.toml b/js/src/rust/Cargo.toml
new file mode 100644
index 0000000000..609a8b0942
--- /dev/null
+++ b/js/src/rust/Cargo.toml
@@ -0,0 +1,22 @@
+[package]
+name = "jsrust"
+version = "0.1.0"
+authors = ["The Spidermonkey developers"]
+license = "MPL-2.0"
+
+[lib]
+name = "jsrust"
+crate-type = ["staticlib"]
+path = "lib.rs"
+
+[features]
+moz_memory = ['mozglue-static/moz_memory']
+simd-accel = ['jsrust_shared/simd-accel']
+smoosh = ['jsrust_shared/smoosh']
+gluesmith = ['jsrust_shared/gluesmith']
+
+[dependencies]
+jsrust_shared = { path = "./shared" }
+# Workaround for https://github.com/rust-lang/rust/issues/58393
+mozglue-static = { path = "../../../mozglue/static/rust" }
+wast = "56.0.0"