summaryrefslogtreecommitdiffstats
path: root/js/src/shell/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'js/src/shell/Makefile.in')
-rw-r--r--js/src/shell/Makefile.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/js/src/shell/Makefile.in b/js/src/shell/Makefile.in
new file mode 100644
index 0000000000..3ce017a08d
--- /dev/null
+++ b/js/src/shell/Makefile.in
@@ -0,0 +1,16 @@
+# -*- Mode: makefile -*-
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+ifdef QEMU_EXE
+MOZ_POST_PROGRAM_COMMAND = $(topsrcdir)/build/qemu-wrap --qemu $(QEMU_EXE) --libdir $(CROSS_LIB)
+endif
+
+include $(topsrcdir)/config/rules.mk
+
+# Install versioned binary for parallel installability in Linux distributions
+install:: $(PROGRAM)
+ cp $^ $(basename $^)$(MOZJS_MAJOR_VERSION)$(suffix $^)
+ $(SYSINSTALL) $(basename $^)$(MOZJS_MAJOR_VERSION)$(suffix $^) $(DESTDIR)$(bindir)