summaryrefslogtreecommitdiffstats
path: root/layout/generic/crashtests/394237-1.html
diff options
context:
space:
mode:
Diffstat (limited to 'layout/generic/crashtests/394237-1.html')
-rw-r--r--layout/generic/crashtests/394237-1.html38
1 files changed, 38 insertions, 0 deletions
diff --git a/layout/generic/crashtests/394237-1.html b/layout/generic/crashtests/394237-1.html
new file mode 100644
index 0000000000..8fc1bc8b09
--- /dev/null
+++ b/layout/generic/crashtests/394237-1.html
@@ -0,0 +1,38 @@
+<html xmlns="http://www.w3.org/1999/xhtml">
+<head>
+<style>
+
+body {
+ height: 50px;
+ column-count: 2;
+}
+.container {
+ height: 10px;
+}
+.overflow {
+ height: 100px;
+}
+.bb {
+ border-bottom: solid 4px magenta;
+}
+
+</style>
+
+<script>
+
+function boom()
+{
+ document.getElementById("x").setAttribute("class", "");
+ document.getElementById("y").setAttribute("class", "bb");
+}
+
+</script>
+</head>
+
+<body onload="boom();">
+ <div class="container"><div class="overflow" id="x"></div></div>
+ <div id="y"></div>
+ <div class="container"><div class="overflow"></div></div>
+</body>
+
+</html>