summaryrefslogtreecommitdiffstats
path: root/python/mozlint/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'python/mozlint/setup.py')
-rw-r--r--python/mozlint/setup.py26
1 files changed, 26 insertions, 0 deletions
diff --git a/python/mozlint/setup.py b/python/mozlint/setup.py
new file mode 100644
index 0000000000..c16e15fd7f
--- /dev/null
+++ b/python/mozlint/setup.py
@@ -0,0 +1,26 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+from setuptools import setup
+
+VERSION = 0.1
+DEPS = ["mozlog >= 6.0"]
+
+setup(
+ name="mozlint",
+ description="Framework for registering and running micro lints",
+ license="MPL 2.0",
+ author="Andrew Halberstadt",
+ author_email="ahalberstadt@mozilla.com",
+ url="",
+ packages=["mozlint"],
+ version=VERSION,
+ classifiers=[
+ "Environment :: Console",
+ "Development Status :: 3 - Alpha",
+ "License :: OSI Approved :: Mozilla Public License 2.0 (MPL 2.0)",
+ "Natural Language :: English",
+ ],
+ install_requires=DEPS,
+)