summaryrefslogtreecommitdiffstats
path: root/python/mozperftest/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'python/mozperftest/setup.py')
-rw-r--r--python/mozperftest/setup.py37
1 files changed, 37 insertions, 0 deletions
diff --git a/python/mozperftest/setup.py b/python/mozperftest/setup.py
new file mode 100644
index 0000000000..75ebab9305
--- /dev/null
+++ b/python/mozperftest/setup.py
@@ -0,0 +1,37 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this file,
+# You can obtain one at http://mozilla.org/MPL/2.0/.
+
+from setuptools import setup
+
+PACKAGE_NAME = "mozperftest"
+PACKAGE_VERSION = "0.2"
+
+deps = [
+ "regex",
+ "jsonschema",
+ "attr",
+ "mozlog >= 6.0",
+ "mozdevice >= 4.0.0",
+ "mozproxy",
+ "mozinfo",
+ "mozfile",
+ "mozperftest-tools",
+]
+
+setup(
+ name=PACKAGE_NAME,
+ version=PACKAGE_VERSION,
+ description="Mozilla's mach perftest command",
+ classifiers=["Programming Language :: Python :: 3.6"],
+ # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+ keywords="",
+ author="Mozilla Performance Test Engineering Team",
+ author_email="tools@lists.mozilla.org",
+ url="https://hg.mozilla.org/mozilla-central/file/tip/python/mozperftest",
+ license="MPL",
+ packages=["mozperftest"],
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=deps,
+)