summaryrefslogtreecommitdiffstats
path: root/python/mozrelease/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'python/mozrelease/setup.py')
-rw-r--r--python/mozrelease/setup.py25
1 files changed, 25 insertions, 0 deletions
diff --git a/python/mozrelease/setup.py b/python/mozrelease/setup.py
new file mode 100644
index 0000000000..d831cb14c5
--- /dev/null
+++ b/python/mozrelease/setup.py
@@ -0,0 +1,25 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+from setuptools import find_packages, setup
+
+VERSION = "0.2"
+
+setup(
+ author="Mozilla Foundation",
+ author_email="Mozilla Release Engineering",
+ name="mozrelease",
+ description="Common functionality used by Mozilla Release Automation",
+ license="MPL 2.0",
+ packages=find_packages(),
+ version=VERSION,
+ classifiers=[
+ "Development Status :: 3 - Alpha",
+ "Topic :: Software Development :: Build Tools",
+ "License :: OSI Approved :: Mozilla Public License 2.0 (MPL 2.0)",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: Implementation :: CPython",
+ ],
+ keywords="mozilla",
+)