summaryrefslogtreecommitdiffstats
path: root/testing/mochitest/pywebsocket3/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mochitest/pywebsocket3/README.md')
-rw-r--r--testing/mochitest/pywebsocket3/README.md36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/mochitest/pywebsocket3/README.md b/testing/mochitest/pywebsocket3/README.md
new file mode 100644
index 0000000000..277cbe550c
--- /dev/null
+++ b/testing/mochitest/pywebsocket3/README.md
@@ -0,0 +1,36 @@
+
+# pywebsocket3 #
+
+The pywebsocket project aims to provide a [WebSocket](https://tools.ietf.org/html/rfc6455) standalone server.
+
+pywebsocket is intended for **testing** or **experimental** purposes.
+
+Run this to read the general document:
+```
+$ pydoc mod_pywebsocket
+```
+
+Please see [Wiki](../../wiki) for more details.
+
+# INSTALL #
+
+To install this package to the system, run this:
+```
+$ python setup.py build
+$ sudo python setup.py install
+```
+
+To install this package as a normal user, run this instead:
+
+```
+$ python setup.py build
+$ python setup.py install --user
+```
+# LAUNCH #
+
+To use pywebsocket as standalone server, run this to read the document:
+```
+$ pydoc mod_pywebsocket.standalone
+```
+# Disclaimer #
+This is not an officially supported Google product