summaryrefslogtreecommitdiffstats
path: root/testing/mozbase/rust/mozprofile/fuzz
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mozbase/rust/mozprofile/fuzz')
-rw-r--r--testing/mozbase/rust/mozprofile/fuzz/Cargo.toml25
-rw-r--r--testing/mozbase/rust/mozprofile/fuzz/fuzz_targets/prefreader.rs16
2 files changed, 41 insertions, 0 deletions
diff --git a/testing/mozbase/rust/mozprofile/fuzz/Cargo.toml b/testing/mozbase/rust/mozprofile/fuzz/Cargo.toml
new file mode 100644
index 0000000000..53e116143c
--- /dev/null
+++ b/testing/mozbase/rust/mozprofile/fuzz/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "mozprofile-fuzz"
+version = "0.0.0"
+authors = ["Automatically generated"]
+publish = false
+edition = "2018"
+
+[package.metadata]
+cargo-fuzz = true
+
+[dependencies]
+libfuzzer-sys = "0.4"
+
+[dependencies.mozprofile]
+path = ".."
+
+# Prevent this from interfering with workspaces
+[workspace]
+members = ["."]
+
+[[bin]]
+name = "prefreader"
+path = "fuzz_targets/prefreader.rs"
+test = false
+doc = false
diff --git a/testing/mozbase/rust/mozprofile/fuzz/fuzz_targets/prefreader.rs b/testing/mozbase/rust/mozprofile/fuzz/fuzz_targets/prefreader.rs
new file mode 100644
index 0000000000..824eb3c31e
--- /dev/null
+++ b/testing/mozbase/rust/mozprofile/fuzz/fuzz_targets/prefreader.rs
@@ -0,0 +1,16 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+#![no_main]
+use libfuzzer_sys::fuzz_target;
+use std::io::Cursor;
+extern crate mozprofile;
+
+fuzz_target!(|data: &[u8]| {
+ let buf = Vec::new();
+ let mut out = Cursor::new(buf);
+ mozprofile::prefreader::parse(data).map(|parsed| {
+ mozprofile::prefreader::serialize(&parsed, &mut out);
+ });
+});