summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/dom/nodes/remove-from-shadow-host-and-adopt-into-iframe.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/dom/nodes/remove-from-shadow-host-and-adopt-into-iframe.html')
-rw-r--r--testing/web-platform/tests/dom/nodes/remove-from-shadow-host-and-adopt-into-iframe.html29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/web-platform/tests/dom/nodes/remove-from-shadow-host-and-adopt-into-iframe.html b/testing/web-platform/tests/dom/nodes/remove-from-shadow-host-and-adopt-into-iframe.html
new file mode 100644
index 0000000000..612aed637d
--- /dev/null
+++ b/testing/web-platform/tests/dom/nodes/remove-from-shadow-host-and-adopt-into-iframe.html
@@ -0,0 +1,29 @@
+<!doctype html>
+<html class="reftest-wait">
+ <head>
+ <title>Adopting a shadow host child into an iframe</title>
+ <link rel="help" href="https://dom.spec.whatwg.org/#concept-node-adopt">
+ <link rel="match" href="remove-from-shadow-host-and-adopt-into-iframe-ref.html">
+ <style>
+ iframe { border: 0; }
+ </style>
+ <script src="/common/reftest-wait.js"></script>
+ <script>
+ onload = () => {
+ const root = host.attachShadow({mode:"open"});
+ root.innerHTML = "<slot>";
+ // force a layout
+ host.offsetTop;
+ iframe.contentWindow.document.body.style.margin = 0;
+ iframe.contentWindow.document.body.appendChild(adopted);
+ host.remove();
+ takeScreenshot();
+ }
+ </script>
+ </head>
+ <body>
+ <p>You should see the word PASS below.</p>
+ <iframe id="iframe"></iframe>
+ <div id="host"><span id="adopted">PASS</span></div>
+ </body>
+</html>