summaryrefslogtreecommitdiffstats
path: root/third_party/python/json-e/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/python/json-e/setup.py')
-rw-r--r--third_party/python/json-e/setup.py31
1 files changed, 31 insertions, 0 deletions
diff --git a/third_party/python/json-e/setup.py b/third_party/python/json-e/setup.py
new file mode 100644
index 0000000000..76299df9be
--- /dev/null
+++ b/third_party/python/json-e/setup.py
@@ -0,0 +1,31 @@
+import json
+import os
+from setuptools import setup, find_packages
+
+package_json = os.path.join(os.path.dirname(os.path.abspath(__file__)), 'package.json')
+with open(package_json) as f:
+ version = json.load(f)['version']
+
+setup(name='json-e',
+ version=version,
+ description='A data-structure parameterization system written for embedding context in JSON objects',
+ author='Dustin J. Mitchell',
+ url='https://taskcluster.github.io/json-e/',
+ author_email='dustin@mozilla.com',
+ packages=['jsone'],
+ test_suite='nose.collector',
+ license='MPL2',
+ extras_require={
+ 'release': [
+ 'towncrier',
+ ],
+ },
+ tests_require=[
+ "freezegun",
+ "hypothesis",
+ "nose",
+ "PyYAML",
+ "python-dateutil",
+ 'pep8',
+ ]
+)