summaryrefslogtreecommitdiffstats
path: root/third_party/rust/atomic_refcell
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/atomic_refcell')
-rw-r--r--third_party/rust/atomic_refcell/.cargo-checksum.json1
-rw-r--r--third_party/rust/atomic_refcell/Cargo.toml22
-rw-r--r--third_party/rust/atomic_refcell/LICENSE.APACHE201
-rw-r--r--third_party/rust/atomic_refcell/LICENSE.MIT21
-rw-r--r--third_party/rust/atomic_refcell/README.md2
-rw-r--r--third_party/rust/atomic_refcell/benches/basic.rs37
-rw-r--r--third_party/rust/atomic_refcell/src/lib.rs482
-rw-r--r--third_party/rust/atomic_refcell/tests/basic.rs156
8 files changed, 922 insertions, 0 deletions
diff --git a/third_party/rust/atomic_refcell/.cargo-checksum.json b/third_party/rust/atomic_refcell/.cargo-checksum.json
new file mode 100644
index 0000000000..d1b1a40d22
--- /dev/null
+++ b/third_party/rust/atomic_refcell/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"dd91a57271a7ab33c6c4d7c76e010f9e5ff68414690c40a1918fb57818cb0768","LICENSE.APACHE":"c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4","LICENSE.MIT":"d8e997e6cdf64acfdd3a9315b5dea0dd933f1f5386a55a2c16916dc8514071f2","README.md":"6b468f17809063c5dcee5758d1daca147d74e2297a9dc78a5e50ae13d9ea6e42","benches/basic.rs":"aba00ab044b37a7fb4e5c855cf88a323a04d6143b651717e227fdd12735602f3","src/lib.rs":"d65e83920e9f56de931331cb64588c9511e76466fc6d5dd2872d701dcb8b7e9c","tests/basic.rs":"2cefa20188254d8357a595975733ad1bffb4de90933d5d9e9caa17232c1d646b"},"package":"857253367827bd9d0fd973f0ef15506a96e79e41b0ad7aa691203a4e3214f6c8"} \ No newline at end of file
diff --git a/third_party/rust/atomic_refcell/Cargo.toml b/third_party/rust/atomic_refcell/Cargo.toml
new file mode 100644
index 0000000000..56cc6dd538
--- /dev/null
+++ b/third_party/rust/atomic_refcell/Cargo.toml
@@ -0,0 +1,22 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "atomic_refcell"
+version = "0.1.9"
+authors = ["Bobby Holley <bobbyholley@gmail.com>"]
+description = "Threadsafe RefCell"
+documentation = "https://docs.rs/atomic_refcell/"
+readme = "README.md"
+license = "Apache-2.0/MIT"
+repository = "https://github.com/bholley/atomic_refcell"
+
+[dependencies]
diff --git a/third_party/rust/atomic_refcell/LICENSE.APACHE b/third_party/rust/atomic_refcell/LICENSE.APACHE
new file mode 100644
index 0000000000..261eeb9e9f
--- /dev/null
+++ b/third_party/rust/atomic_refcell/LICENSE.APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+ TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+ 1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+ 2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+ 3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+ 4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+ 5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+ 6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+ 7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+ 8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+ 9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+ END OF TERMS AND CONDITIONS
+
+ APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+ Copyright [yyyy] [name of copyright owner]
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
diff --git a/third_party/rust/atomic_refcell/LICENSE.MIT b/third_party/rust/atomic_refcell/LICENSE.MIT
new file mode 100644
index 0000000000..bfc9986a15
--- /dev/null
+++ b/third_party/rust/atomic_refcell/LICENSE.MIT
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2022 Bobby Holley
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/third_party/rust/atomic_refcell/README.md b/third_party/rust/atomic_refcell/README.md
new file mode 100644
index 0000000000..de72c55daa
--- /dev/null
+++ b/third_party/rust/atomic_refcell/README.md
@@ -0,0 +1,2 @@
+# atomic_refcell
+Threadsafe RefCell for Rust.
diff --git a/third_party/rust/atomic_refcell/benches/basic.rs b/third_party/rust/atomic_refcell/benches/basic.rs
new file mode 100644
index 0000000000..3902a98a37
--- /dev/null
+++ b/third_party/rust/atomic_refcell/benches/basic.rs
@@ -0,0 +1,37 @@
+#![feature(test)]
+
+extern crate atomic_refcell;
+extern crate test;
+
+use atomic_refcell::AtomicRefCell;
+use test::Bencher;
+
+#[derive(Default)]
+struct Bar(u32);
+
+#[bench]
+fn immutable_borrow(b: &mut Bencher) {
+ let a = AtomicRefCell::new(Bar::default());
+ b.iter(|| a.borrow());
+}
+
+#[bench]
+fn immutable_second_borrow(b: &mut Bencher) {
+ let a = AtomicRefCell::new(Bar::default());
+ let _first = a.borrow();
+ b.iter(|| a.borrow());
+}
+
+#[bench]
+fn immutable_third_borrow(b: &mut Bencher) {
+ let a = AtomicRefCell::new(Bar::default());
+ let _first = a.borrow();
+ let _second = a.borrow();
+ b.iter(|| a.borrow());
+}
+
+#[bench]
+fn mutable_borrow(b: &mut Bencher) {
+ let a = AtomicRefCell::new(Bar::default());
+ b.iter(|| a.borrow_mut());
+}
diff --git a/third_party/rust/atomic_refcell/src/lib.rs b/third_party/rust/atomic_refcell/src/lib.rs
new file mode 100644
index 0000000000..b1afc324e7
--- /dev/null
+++ b/third_party/rust/atomic_refcell/src/lib.rs
@@ -0,0 +1,482 @@
+//! Implements a container type providing RefCell-like semantics for objects
+//! shared across threads.
+//!
+//! RwLock is traditionally considered to be the |Sync| analogue of RefCell.
+//! However, for consumers that can guarantee that they will never mutably
+//! borrow the contents concurrently with immutable borrows, an RwLock is
+//! overkill, and has key disadvantages:
+//! * Performance: Even the fastest existing implementation of RwLock (that of
+//! parking_lot) performs at least two atomic operations during immutable
+//! borrows. This makes mutable borrows significantly cheaper than immutable
+//! borrows, leading to weird incentives when writing performance-critical
+//! code.
+//! * Features: Implementing AtomicRefCell on top of RwLock makes it impossible
+//! to implement useful things like AtomicRef{,Mut}::map.
+//!
+//! As such, we re-implement RefCell semantics from scratch with a single atomic
+//! reference count. The primary complication of this scheme relates to keeping
+//! things in a consistent state when one thread performs an illegal borrow and
+//! panics. Since an AtomicRefCell can be accessed by multiple threads, and since
+//! panics are recoverable, we need to ensure that an illegal (panicking) access by
+//! one thread does not lead to undefined behavior on other, still-running threads.
+//!
+//! So we represent things as follows:
+//! * Any value with the high bit set (so half the total refcount space) indicates
+//! a mutable borrow.
+//! * Mutable borrows perform an atomic compare-and-swap, swapping in the high bit
+//! if the current value is zero. If the current value is non-zero, the thread
+//! panics and the value is left undisturbed.
+//! * Immutable borrows perform an atomic increment. If the new value has the high
+//! bit set, the thread panics. The incremented refcount is left as-is, since it
+//! still represents a valid mutable borrow. When the mutable borrow is released,
+//! the refcount is set unconditionally to zero, clearing any stray increments by
+//! panicked threads.
+//!
+//! There are a few additional purely-academic complications to handle overflow,
+//! which are documented in the implementation.
+//!
+//! The rest of this module is mostly derived by copy-pasting the implementation of
+//! RefCell and fixing things up as appropriate. Certain non-threadsafe methods
+//! have been removed. We segment the concurrency logic from the rest of the code to
+//! keep the tricky parts small and easy to audit.
+
+#![no_std]
+#![allow(unsafe_code)]
+#![deny(missing_docs)]
+
+use core::cell::UnsafeCell;
+use core::cmp;
+use core::fmt;
+use core::fmt::{Debug, Display};
+use core::ops::{Deref, DerefMut};
+use core::sync::atomic;
+use core::sync::atomic::AtomicUsize;
+
+/// A threadsafe analogue to RefCell.
+pub struct AtomicRefCell<T: ?Sized> {
+ borrow: AtomicUsize,
+ value: UnsafeCell<T>,
+}
+
+/// An error returned by [`AtomicRefCell::try_borrow`](struct.AtomicRefCell.html#method.try_borrow).
+pub struct BorrowError {
+ _private: (),
+}
+
+impl Debug for BorrowError {
+ fn fmt(&self, f: &mut fmt::Formatter<'_>) -> fmt::Result {
+ f.debug_struct("BorrowError").finish()
+ }
+}
+
+impl Display for BorrowError {
+ fn fmt(&self, f: &mut fmt::Formatter<'_>) -> fmt::Result {
+ Display::fmt("already mutably borrowed", f)
+ }
+}
+
+/// An error returned by [`AtomicRefCell::try_borrow_mut`](struct.AtomicRefCell.html#method.try_borrow_mut).
+pub struct BorrowMutError {
+ _private: (),
+}
+
+impl Debug for BorrowMutError {
+ fn fmt(&self, f: &mut fmt::Formatter<'_>) -> fmt::Result {
+ f.debug_struct("BorrowMutError").finish()
+ }
+}
+
+impl Display for BorrowMutError {
+ fn fmt(&self, f: &mut fmt::Formatter<'_>) -> fmt::Result {
+ Display::fmt("already borrowed", f)
+ }
+}
+
+impl<T> AtomicRefCell<T> {
+ /// Creates a new `AtomicRefCell` containing `value`.
+ #[inline]
+ pub const fn new(value: T) -> AtomicRefCell<T> {
+ AtomicRefCell {
+ borrow: AtomicUsize::new(0),
+ value: UnsafeCell::new(value),
+ }
+ }
+
+ /// Consumes the `AtomicRefCell`, returning the wrapped value.
+ #[inline]
+ pub fn into_inner(self) -> T {
+ debug_assert!(self.borrow.load(atomic::Ordering::Acquire) == 0);
+ self.value.into_inner()
+ }
+}
+
+impl<T: ?Sized> AtomicRefCell<T> {
+ /// Immutably borrows the wrapped value.
+ #[inline]
+ pub fn borrow(&self) -> AtomicRef<T> {
+ match AtomicBorrowRef::try_new(&self.borrow) {
+ Ok(borrow) => AtomicRef {
+ value: unsafe { &*self.value.get() },
+ borrow,
+ },
+ Err(s) => panic!("{}", s),
+ }
+ }
+
+ /// Attempts to immutably borrow the wrapped value, but instead of panicking
+ /// on a failed borrow, returns `Err`.
+ #[inline]
+ pub fn try_borrow(&self) -> Result<AtomicRef<T>, BorrowError> {
+ match AtomicBorrowRef::try_new(&self.borrow) {
+ Ok(borrow) => Ok(AtomicRef {
+ value: unsafe { &*self.value.get() },
+ borrow,
+ }),
+ Err(_) => Err(BorrowError { _private: () }),
+ }
+ }
+
+ /// Mutably borrows the wrapped value.
+ #[inline]
+ pub fn borrow_mut(&self) -> AtomicRefMut<T> {
+ match AtomicBorrowRefMut::try_new(&self.borrow) {
+ Ok(borrow) => AtomicRefMut {
+ value: unsafe { &mut *self.value.get() },
+ borrow,
+ },
+ Err(s) => panic!("{}", s),
+ }
+ }
+
+ /// Attempts to mutably borrow the wrapped value, but instead of panicking
+ /// on a failed borrow, returns `Err`.
+ #[inline]
+ pub fn try_borrow_mut(&self) -> Result<AtomicRefMut<T>, BorrowMutError> {
+ match AtomicBorrowRefMut::try_new(&self.borrow) {
+ Ok(borrow) => Ok(AtomicRefMut {
+ value: unsafe { &mut *self.value.get() },
+ borrow,
+ }),
+ Err(_) => Err(BorrowMutError { _private: () }),
+ }
+ }
+
+ /// Returns a raw pointer to the underlying data in this cell.
+ ///
+ /// External synchronization is needed to avoid data races when dereferencing
+ /// the pointer.
+ #[inline]
+ pub fn as_ptr(&self) -> *mut T {
+ self.value.get()
+ }
+
+ /// Returns a mutable reference to the wrapped value.
+ ///
+ /// No runtime checks take place (unless debug assertions are enabled)
+ /// because this call borrows `AtomicRefCell` mutably at compile-time.
+ #[inline]
+ pub fn get_mut(&mut self) -> &mut T {
+ debug_assert!(self.borrow.load(atomic::Ordering::Acquire) == 0);
+ unsafe { &mut *self.value.get() }
+ }
+}
+
+//
+// Core synchronization logic. Keep this section small and easy to audit.
+//
+
+const HIGH_BIT: usize = !(::core::usize::MAX >> 1);
+const MAX_FAILED_BORROWS: usize = HIGH_BIT + (HIGH_BIT >> 1);
+
+struct AtomicBorrowRef<'b> {
+ borrow: &'b AtomicUsize,
+}
+
+impl<'b> AtomicBorrowRef<'b> {
+ #[inline]
+ fn try_new(borrow: &'b AtomicUsize) -> Result<Self, &'static str> {
+ let new = borrow.fetch_add(1, atomic::Ordering::Acquire) + 1;
+ if new & HIGH_BIT != 0 {
+ // If the new count has the high bit set, that almost certainly
+ // means there's an pre-existing mutable borrow. In that case,
+ // we simply leave the increment as a benign side-effect and
+ // return `Err`. Once the mutable borrow is released, the
+ // count will be reset to zero unconditionally.
+ //
+ // The overflow check here ensures that an unbounded number of
+ // immutable borrows during the scope of one mutable borrow
+ // will soundly trigger a panic (or abort) rather than UB.
+ Self::check_overflow(borrow, new);
+ Err("already mutably borrowed")
+ } else {
+ Ok(AtomicBorrowRef { borrow: borrow })
+ }
+ }
+
+ #[cold]
+ #[inline(never)]
+ fn check_overflow(borrow: &'b AtomicUsize, new: usize) {
+ if new == HIGH_BIT {
+ // We overflowed into the reserved upper half of the refcount
+ // space. Before panicking, decrement the refcount to leave things
+ // in a consistent immutable-borrow state.
+ //
+ // This can basically only happen if somebody forget()s AtomicRefs
+ // in a tight loop.
+ borrow.fetch_sub(1, atomic::Ordering::Release);
+ panic!("too many immutable borrows");
+ } else if new >= MAX_FAILED_BORROWS {
+ // During the mutable borrow, an absurd number of threads have
+ // attempted to increment the refcount with immutable borrows.
+ // To avoid hypothetically wrapping the refcount, we abort the
+ // process once a certain threshold is reached.
+ //
+ // This requires billions of borrows to fail during the scope of
+ // one mutable borrow, and so is very unlikely to happen in a real
+ // program.
+ //
+ // To avoid a potential unsound state after overflowing, we make
+ // sure the entire process aborts.
+ //
+ // Right now, there's no stable way to do that without `std`:
+ // https://github.com/rust-lang/rust/issues/67952
+ // As a workaround, we cause an abort by making this thread panic
+ // during the unwinding of another panic.
+ //
+ // On platforms where the panic strategy is already 'abort', the
+ // ForceAbort object here has no effect, as the program already
+ // panics before it is dropped.
+ struct ForceAbort;
+ impl Drop for ForceAbort {
+ fn drop(&mut self) {
+ panic!("Aborting to avoid unsound state of AtomicRefCell");
+ }
+ }
+ let _abort = ForceAbort;
+ panic!("Too many failed borrows");
+ }
+ }
+}
+
+impl<'b> Drop for AtomicBorrowRef<'b> {
+ #[inline]
+ fn drop(&mut self) {
+ let old = self.borrow.fetch_sub(1, atomic::Ordering::Release);
+ // This assertion is technically incorrect in the case where another
+ // thread hits the hypothetical overflow case, since we might observe
+ // the refcount before it fixes it up (and panics). But that never will
+ // never happen in a real program, and this is a debug_assert! anyway.
+ debug_assert!(old & HIGH_BIT == 0);
+ }
+}
+
+struct AtomicBorrowRefMut<'b> {
+ borrow: &'b AtomicUsize,
+}
+
+impl<'b> Drop for AtomicBorrowRefMut<'b> {
+ #[inline]
+ fn drop(&mut self) {
+ self.borrow.store(0, atomic::Ordering::Release);
+ }
+}
+
+impl<'b> AtomicBorrowRefMut<'b> {
+ #[inline]
+ fn try_new(borrow: &'b AtomicUsize) -> Result<AtomicBorrowRefMut<'b>, &'static str> {
+ // Use compare-and-swap to avoid corrupting the immutable borrow count
+ // on illegal mutable borrows.
+ let old = match borrow.compare_exchange(
+ 0,
+ HIGH_BIT,
+ atomic::Ordering::Acquire,
+ atomic::Ordering::Relaxed,
+ ) {
+ Ok(x) => x,
+ Err(x) => x,
+ };
+
+ if old == 0 {
+ Ok(AtomicBorrowRefMut { borrow })
+ } else if old & HIGH_BIT == 0 {
+ Err("already immutably borrowed")
+ } else {
+ Err("already mutably borrowed")
+ }
+ }
+}
+
+unsafe impl<T: ?Sized + Send> Send for AtomicRefCell<T> {}
+unsafe impl<T: ?Sized + Send + Sync> Sync for AtomicRefCell<T> {}
+
+//
+// End of core synchronization logic. No tricky thread stuff allowed below
+// this point.
+//
+
+impl<T: Clone> Clone for AtomicRefCell<T> {
+ #[inline]
+ fn clone(&self) -> AtomicRefCell<T> {
+ AtomicRefCell::new(self.borrow().clone())
+ }
+}
+
+impl<T: Default> Default for AtomicRefCell<T> {
+ #[inline]
+ fn default() -> AtomicRefCell<T> {
+ AtomicRefCell::new(Default::default())
+ }
+}
+
+impl<T: ?Sized + PartialEq> PartialEq for AtomicRefCell<T> {
+ #[inline]
+ fn eq(&self, other: &AtomicRefCell<T>) -> bool {
+ *self.borrow() == *other.borrow()
+ }
+}
+
+impl<T: ?Sized + Eq> Eq for AtomicRefCell<T> {}
+
+impl<T: ?Sized + PartialOrd> PartialOrd for AtomicRefCell<T> {
+ #[inline]
+ fn partial_cmp(&self, other: &AtomicRefCell<T>) -> Option<cmp::Ordering> {
+ self.borrow().partial_cmp(&*other.borrow())
+ }
+}
+
+impl<T: ?Sized + Ord> Ord for AtomicRefCell<T> {
+ #[inline]
+ fn cmp(&self, other: &AtomicRefCell<T>) -> cmp::Ordering {
+ self.borrow().cmp(&*other.borrow())
+ }
+}
+
+impl<T> From<T> for AtomicRefCell<T> {
+ fn from(t: T) -> AtomicRefCell<T> {
+ AtomicRefCell::new(t)
+ }
+}
+
+impl<'b> Clone for AtomicBorrowRef<'b> {
+ #[inline]
+ fn clone(&self) -> AtomicBorrowRef<'b> {
+ AtomicBorrowRef::try_new(self.borrow).unwrap()
+ }
+}
+
+/// A wrapper type for an immutably borrowed value from an `AtomicRefCell<T>`.
+pub struct AtomicRef<'b, T: ?Sized + 'b> {
+ value: &'b T,
+ borrow: AtomicBorrowRef<'b>,
+}
+
+impl<'b, T: ?Sized> Deref for AtomicRef<'b, T> {
+ type Target = T;
+
+ #[inline]
+ fn deref(&self) -> &T {
+ self.value
+ }
+}
+
+impl<'b, T: ?Sized> AtomicRef<'b, T> {
+ /// Copies an `AtomicRef`.
+ #[inline]
+ pub fn clone(orig: &AtomicRef<'b, T>) -> AtomicRef<'b, T> {
+ AtomicRef {
+ value: orig.value,
+ borrow: orig.borrow.clone(),
+ }
+ }
+
+ /// Make a new `AtomicRef` for a component of the borrowed data.
+ #[inline]
+ pub fn map<U: ?Sized, F>(orig: AtomicRef<'b, T>, f: F) -> AtomicRef<'b, U>
+ where
+ F: FnOnce(&T) -> &U,
+ {
+ AtomicRef {
+ value: f(orig.value),
+ borrow: orig.borrow,
+ }
+ }
+
+ /// Make a new `AtomicRef` for an optional component of the borrowed data.
+ #[inline]
+ pub fn filter_map<U: ?Sized, F>(orig: AtomicRef<'b, T>, f: F) -> Option<AtomicRef<'b, U>>
+ where
+ F: FnOnce(&T) -> Option<&U>,
+ {
+ Some(AtomicRef {
+ value: f(orig.value)?,
+ borrow: orig.borrow,
+ })
+ }
+}
+
+impl<'b, T: ?Sized> AtomicRefMut<'b, T> {
+ /// Make a new `AtomicRefMut` for a component of the borrowed data, e.g. an enum
+ /// variant.
+ #[inline]
+ pub fn map<U: ?Sized, F>(orig: AtomicRefMut<'b, T>, f: F) -> AtomicRefMut<'b, U>
+ where
+ F: FnOnce(&mut T) -> &mut U,
+ {
+ AtomicRefMut {
+ value: f(orig.value),
+ borrow: orig.borrow,
+ }
+ }
+
+ /// Make a new `AtomicRefMut` for an optional component of the borrowed data.
+ #[inline]
+ pub fn filter_map<U: ?Sized, F>(orig: AtomicRefMut<'b, T>, f: F) -> Option<AtomicRefMut<'b, U>>
+ where
+ F: FnOnce(&mut T) -> Option<&mut U>,
+ {
+ Some(AtomicRefMut {
+ value: f(orig.value)?,
+ borrow: orig.borrow,
+ })
+ }
+}
+
+/// A wrapper type for a mutably borrowed value from an `AtomicRefCell<T>`.
+pub struct AtomicRefMut<'b, T: ?Sized + 'b> {
+ value: &'b mut T,
+ borrow: AtomicBorrowRefMut<'b>,
+}
+
+impl<'b, T: ?Sized> Deref for AtomicRefMut<'b, T> {
+ type Target = T;
+
+ #[inline]
+ fn deref(&self) -> &T {
+ self.value
+ }
+}
+
+impl<'b, T: ?Sized> DerefMut for AtomicRefMut<'b, T> {
+ #[inline]
+ fn deref_mut(&mut self) -> &mut T {
+ self.value
+ }
+}
+
+impl<'b, T: ?Sized + Debug + 'b> Debug for AtomicRef<'b, T> {
+ fn fmt(&self, f: &mut fmt::Formatter) -> fmt::Result {
+ self.value.fmt(f)
+ }
+}
+
+impl<'b, T: ?Sized + Debug + 'b> Debug for AtomicRefMut<'b, T> {
+ fn fmt(&self, f: &mut fmt::Formatter) -> fmt::Result {
+ self.value.fmt(f)
+ }
+}
+
+impl<T: ?Sized + Debug> Debug for AtomicRefCell<T> {
+ fn fmt(&self, f: &mut fmt::Formatter) -> fmt::Result {
+ write!(f, "AtomicRefCell {{ ... }}")
+ }
+}
diff --git a/third_party/rust/atomic_refcell/tests/basic.rs b/third_party/rust/atomic_refcell/tests/basic.rs
new file mode 100644
index 0000000000..a37833085d
--- /dev/null
+++ b/third_party/rust/atomic_refcell/tests/basic.rs
@@ -0,0 +1,156 @@
+extern crate atomic_refcell;
+
+use atomic_refcell::{AtomicRef, AtomicRefCell, AtomicRefMut};
+
+#[derive(Debug)]
+struct Foo {
+ u: u32,
+}
+
+#[derive(Debug)]
+struct Bar {
+ f: Foo,
+}
+
+impl Default for Bar {
+ fn default() -> Self {
+ Bar { f: Foo { u: 42 } }
+ }
+}
+
+// FIXME(bholley): Add tests to exercise this in concurrent scenarios.
+
+#[test]
+fn immutable() {
+ let a = AtomicRefCell::new(Bar::default());
+ let _first = a.borrow();
+ let _second = a.borrow();
+}
+
+#[test]
+fn try_immutable() {
+ let a = AtomicRefCell::new(Bar::default());
+ let _first = a.try_borrow().unwrap();
+ let _second = a.try_borrow().unwrap();
+}
+
+#[test]
+fn mutable() {
+ let a = AtomicRefCell::new(Bar::default());
+ let _ = a.borrow_mut();
+}
+
+#[test]
+fn try_mutable() {
+ let a = AtomicRefCell::new(Bar::default());
+ let _ = a.try_borrow_mut().unwrap();
+}
+
+#[test]
+fn get_mut() {
+ let mut a = AtomicRefCell::new(Bar::default());
+ let _ = a.get_mut();
+}
+
+#[test]
+fn interleaved() {
+ let a = AtomicRefCell::new(Bar::default());
+ {
+ let _ = a.borrow_mut();
+ }
+ {
+ let _first = a.borrow();
+ let _second = a.borrow();
+ }
+ {
+ let _ = a.borrow_mut();
+ }
+}
+
+#[test]
+fn try_interleaved() {
+ let a = AtomicRefCell::new(Bar::default());
+ {
+ let _ = a.try_borrow_mut().unwrap();
+ }
+ {
+ let _first = a.try_borrow().unwrap();
+ let _second = a.try_borrow().unwrap();
+ let _ = a.try_borrow_mut().unwrap_err();
+ }
+ {
+ let _first = a.try_borrow_mut().unwrap();
+ let _ = a.try_borrow().unwrap_err();
+ }
+}
+
+#[test]
+#[should_panic(expected = "already immutably borrowed")]
+fn immutable_then_mutable() {
+ let a = AtomicRefCell::new(Bar::default());
+ let _first = a.borrow();
+ let _second = a.borrow_mut();
+}
+
+#[test]
+fn immutable_then_try_mutable() {
+ let a = AtomicRefCell::new(Bar::default());
+ let _first = a.borrow();
+ let _second = a.try_borrow_mut().unwrap_err();
+}
+
+#[test]
+#[should_panic(expected = "already mutably borrowed")]
+fn mutable_then_immutable() {
+ let a = AtomicRefCell::new(Bar::default());
+ let _first = a.borrow_mut();
+ let _second = a.borrow();
+}
+
+#[test]
+fn mutable_then_try_immutable() {
+ let a = AtomicRefCell::new(Bar::default());
+ let _first = a.borrow_mut();
+ let _second = a.try_borrow().unwrap_err();
+}
+
+#[test]
+#[should_panic(expected = "already mutably borrowed")]
+fn double_mutable() {
+ let a = AtomicRefCell::new(Bar::default());
+ let _first = a.borrow_mut();
+ let _second = a.borrow_mut();
+}
+
+#[test]
+fn mutable_then_try_mutable() {
+ let a = AtomicRefCell::new(Bar::default());
+ let _first = a.borrow_mut();
+ let _second = a.try_borrow_mut().unwrap_err();
+}
+
+#[test]
+fn map() {
+ let a = AtomicRefCell::new(Bar::default());
+ let b = a.borrow();
+ assert_eq!(b.f.u, 42);
+ let c = AtomicRef::map(b, |x| &x.f);
+ assert_eq!(c.u, 42);
+ let d = AtomicRef::map(c, |x| &x.u);
+ assert_eq!(*d, 42);
+}
+
+#[test]
+fn map_mut() {
+ let a = AtomicRefCell::new(Bar::default());
+ let mut b = a.borrow_mut();
+ assert_eq!(b.f.u, 42);
+ b.f.u = 43;
+ let mut c = AtomicRefMut::map(b, |x| &mut x.f);
+ assert_eq!(c.u, 43);
+ c.u = 44;
+ let mut d = AtomicRefMut::map(c, |x| &mut x.u);
+ assert_eq!(*d, 44);
+ *d = 45;
+ assert_eq!(*d, 45);
+}