summaryrefslogtreecommitdiffstats
path: root/third_party/rust/audio_thread_priority/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/audio_thread_priority/Cargo.toml')
-rw-r--r--third_party/rust/audio_thread_priority/Cargo.toml59
1 files changed, 59 insertions, 0 deletions
diff --git a/third_party/rust/audio_thread_priority/Cargo.toml b/third_party/rust/audio_thread_priority/Cargo.toml
new file mode 100644
index 0000000000..188eced2d1
--- /dev/null
+++ b/third_party/rust/audio_thread_priority/Cargo.toml
@@ -0,0 +1,59 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "audio_thread_priority"
+version = "0.26.1"
+authors = ["Paul Adenot <paul@paul.cx>"]
+description = "Bump a thread to real-time priority, for audio work, on Linux, Windows and macOS"
+license = "MPL-2.0"
+repository = "https://github.com/padenot/audio_thread_priority"
+
+[lib]
+name = "audio_thread_priority"
+crate-type = ["staticlib", "rlib"]
+[dependencies.cfg-if]
+version = "0.1"
+
+[dependencies.log]
+version = "0.4"
+
+[dependencies.simple_logger]
+version = "0.4"
+optional = true
+[dev-dependencies.nix]
+version = "0.15.0"
+
+[features]
+default = ["with_dbus", "winapi"]
+terminal-logging = ["simple_logger"]
+with_dbus = ["dbus"]
+[target."cfg(target_os = \"linux\")".dependencies.dbus]
+version = "0.6.4"
+optional = true
+
+[target."cfg(target_os = \"linux\")".dependencies.libc]
+version = "0.2"
+[target."cfg(target_os = \"macos\")".dependencies.libc]
+version = "0.2"
+
+[target."cfg(target_os = \"macos\")".dependencies.mach]
+version = "0.3"
+[target."cfg(target_os = \"windows\")".dependencies.winapi]
+version = "0.3"
+features = ["avrt", "errhandlingapi", "minwindef"]
+optional = true
+
+[target."cfg(target_os = \"windows\")".dependencies.windows]
+version = "^0.32.0"
+features = ["Win32_Foundation", "Win32_System_Threading"]
+optional = true