summaryrefslogtreecommitdiffstats
path: root/third_party/rust/crossbeam-deque/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/crossbeam-deque/Cargo.toml')
-rw-r--r--third_party/rust/crossbeam-deque/Cargo.toml55
1 files changed, 55 insertions, 0 deletions
diff --git a/third_party/rust/crossbeam-deque/Cargo.toml b/third_party/rust/crossbeam-deque/Cargo.toml
new file mode 100644
index 0000000000..4ff10b3538
--- /dev/null
+++ b/third_party/rust/crossbeam-deque/Cargo.toml
@@ -0,0 +1,55 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.38"
+name = "crossbeam-deque"
+version = "0.8.2"
+description = "Concurrent work-stealing deque"
+homepage = "https://github.com/crossbeam-rs/crossbeam/tree/master/crossbeam-deque"
+readme = "README.md"
+keywords = [
+ "chase-lev",
+ "lock-free",
+ "scheduler",
+ "scheduling",
+]
+categories = [
+ "algorithms",
+ "concurrency",
+ "data-structures",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/crossbeam-rs/crossbeam"
+
+[dependencies.cfg-if]
+version = "1"
+
+[dependencies.crossbeam-epoch]
+version = "0.9"
+optional = true
+default-features = false
+
+[dependencies.crossbeam-utils]
+version = "0.8"
+optional = true
+default-features = false
+
+[dev-dependencies.rand]
+version = "0.8"
+
+[features]
+default = ["std"]
+std = [
+ "crossbeam-epoch/std",
+ "crossbeam-utils/std",
+]